• Document: Τεχνολογική Κατεύθυνση Γ Λυκείου
  • Size: 256.79 KB
  • Uploaded: 2019-03-24 05:43:06
  • Status: Successfully converted


Some snippets from your converted document:

Ανάπτυξη Εφαρμογών /Τεχνολογική Κατεύθυνση Γ’ Λυκείου © χ. τζόκας -2009 1 Ανάπτυξη Εφαρμογών /Τεχνολογική Κατεύθυνση Γ’ Λυκείου Θέματα Θεωρίας 1. Ποιες είναι οι τρεις ιδιότητες που πρέπει να διακρίνουν τα υποπρογράμματα. Αναπτύξτε δύο απ’ αυτές 2. Να γράψετε τα τέσσερα πλεονεκτήματα που τμηματικού προγραμματισμού και να αναπτύξετε δύο απ’ αυτά 3. Ποιος είναι ο ρόλος των παραμέτρων ,.σε ποιες κατηγορίες διακρίνονται και ποιοι κανόνες πρέπει να τηρούν οι λίστες των παραμέτρων; 4. Πως ορίζεται μια συνάρτηση και πως μια διαδικασία. Ποιες λειτουργίες μπορεί να εκτελέσει η κάθε μια. Πώς καλούνται; Να εφαρμόσετε αυτά στο παράδειγμα υπολογισμού του μέγιστου δυο αριθμών με τη χρήση και συνάρτησης και διαδικασίας 5. Ποιους τύπους δεδομένων μπορεί να επιστρέψει μια συνάρτηση και πώς γίνεται η επιστροφή στο υποπρόγραμμα – πρόγραμμα που την καλεί; 6. Μπορούμε σε δυο διαφορετικά υποπρογράμματα να χρησιμοποιήσουμε τα ίδια ονόματα μεταβλητών; Αν ναι εξηγήστε 7. Για πόσο χρόνο δεσμεύουν μνήμη οι μεταβλητές ενός υποπρογράμματος; Εξηγήστε με ένα παράδειγμα 8. Τι είναι τα ορίσματα; 9. Τι γνωρίζετε για τη στοίβα χρόνου εκτέλεσης και τι για τις διευθύνσεις επιστροφής Θεωρητικές ασκήσεις 1. ΠΕΡΑΣΜΑ ΚΑΙ ΕΠΙΣΤΡΟΦΗ ΤΙΜΩΝ ΣΕ ΥΠΟΠΡΟΓΡΑΜΜΑΤΑ 1. Δίνεται το παρακάτω πρόγραμμα που καλεί την διαδικασία ΔΟΚΙΜΗ ΠΡΟΓΡΑΜΜΑ ΥΠΟΠΡΟΓΡΑΜΜΑ1 ΜΕΤΑΒΛΗΤΕΣ ΑΚΕΡΑΙΕΣ: Χ,Υ,Ζ ΑΡΧΗ ΔΙΑΒΑΣΕ Χ, Υ ΖΧ+2*Υ ΓΡΑΨΕ Χ, Υ, Ζ ΚΑΛΕΣΕ ΔΟΚΙΜΗ ( Χ,Υ,Ζ) ΓΡΑΨΕ Χ, Υ ,Ζ ΚΑΛΕΣΕ ΔΟΚΙΜΗ ( Υ, Χ, Ζ) ΓΡΑΨΕ Χ, Υ ,Ζ ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ ΔΙΑΔΙΚΑΣΙΑ ΔΟΚΙΜΗ ( Ζ, Χ, Υ ) ΜΕΤΑΒΛΗΤΕΣ ΑΚΕΡΑΙΕΣ: Χ,Υ,Ζ ΑΡΧΗ © χ. τζόκας -2009 2 Ανάπτυξη Εφαρμογών /Τεχνολογική Κατεύθυνση Γ’ Λυκείου Χ 2*Χ+1 Υ Υ+3 Ζ  Χ-Υ ΓΡΑΨΕ Χ,Υ,Ζ ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ Τι θα τυπώσει το πρόγραμμα αν στην είσοδο δοθούν 10,20 ( να κάνετε πίνακα τιμών των μεταβλητών ) 2. Δίνεται το παρακάτω πρόγραμμα που χρησιμοποιεί υποπρογράμματα ΠΡΟΓΡΑΜΜΑ ΥΠΟΠΡΟΓΡΑΜΜΑΤΑ2 ΜΕΤΑΒΛΗΤΕΣ ΑΚΕΡΑΙΕΣ: Χ, Υ, Ζ, Μ, N, R ΑΡΧΗ ΔΙΑΒΑΣΕ Χ ΟΣΟ Χ<>0 ΕΠΑΝΑΛΑΒΕ ΔΙΑΒΑΣΕ Υ, Ζ M FUN1(X, Y) N FUN2(X, Y) ΓΡΑΨΕ X,Υ, Ζ, FUN1(M, Z), FUN2(N, Z) ΔΙΑΒΑΣΕ Χ ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ ΣΥΝΑΡΤΗΣΗ FUN1( A,B):ΑΚΕΡΑΙΑ ΜΕΤΑΒΛΗΤΕΣ ΑΚΕΡΑΙΕΣ: Α,Β ΑΡΧΗ ΑΝ Α<Β ΤΟΤΕ FUN1 A ΑΛΛΙΩΣ FUN1 Β ΤΕΛΟΣ_ΑΝ ΤΕΛΟΣ_ΣΥΝΑΡΤΗΣΗΣ ΣΥΝΑΡΤΗΣΗ FUN2( A,B):ΑΚΕΡΑΙΑ ΜΕΤΑΒΛΗΤΕΣ ΑΚΕΡΑΙΕΣ: Α,Β ΑΡΧΗ ΑΝ Α>Β ΤΟΤΕ FUN2 A ΑΛΛΙΩΣ FUN2 Β ΤΕΛΟΣ_ΑΝ ΤΕΛΟΣ_ΣΥΝΑΡΤΗΣΗΣ Τι θα τυπώσει το πρόγραμμα αν στην είσοδο δοθούν οι αριθμοί 23, 5, 67, 2, 1, 14, - 5, -8, 0, 0 3. Δίνεται το πρόγραμμα © χ. τζόκας -2009 3 Ανάπτυξη Εφαρμογών /Τεχνολογική Κατεύθυνση Γ’ Λυκείου ΠΡΟΓΡΑΜΜΑ ΚΥΡΙΟ ΜΕΤΑΒΛΗΤΕΣ ΑΚΕΡΑΙΕΣ: Α,Β,Γ ΑΡΧΗ ΔΙΑΒΑΣΕ Α, Β, Γ ΚΑΛΕΣΕ ΔΙΑΔ1(Β,Α,Γ) ΓΡΑΨΕ Α, Β, Γ ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ ΔΙΑΔΙΚΑΣΙΑ ΔΙΑΔ1 ( Α,Γ, Β) ΜΕΤΑΒΛΗΤΕΣ ΑΚΕΡΑΙΕΣ: Α,Β,Γ ΑΡΧΗ ΑΑ+3 ΒΒ-2 ΓΑ+Β ΓΡΑΨΕ Α, Β, Γ ΤΕΛΟ

Recently converted files (publicly available):